Reply To: Coding/Naming Conventions
I agree with the issue WRT favor_big and favor_small. It was an oversight from the translation from RandomDistType. I made a note to change them to FavorBig and FavorSmall in the next revision. Everything else that uses “_” is either a constant (and is upper case) or an externally defined type or subprogram.
I avoided an overloaded Rand due to ambiguity of expressions, such as the following:
wait for RV.Rand(1,6) * TPeriod_Clk ;
Make sure to also look at CoveragePkg as I do my first line of randomization using RandCovPoint
As an aside about RandomDistType/SetRandomMode/SetRandomParm, I suspect they will go away in a future version. Since all of the functions that they allowed calling can now able to be called directly, I am not sure the overhead of supporting this is justified.